WorkCenter supports up to Internet Explorer 9 and also 10 in compatibility view. If you are not using Internet Explorer, please switch to Internet Explorer when using WorkCenter.